読者です 読者をやめる 読者になる 読者になる

lennyでのarmadillo開発環境の問題

gccバージョンの違いで弾かれるのか?
lennyはgcc-4.1-baseが4.1.2-25何だけど。etchでは4.1.1-21なんだよね。
んで多分それで下のエラーが出てる。

debian:/home/ippei/cross_build/A220/deb/instlled# dpkg -i libssp0-arm-cross_4.1.1-21_all.deb 
(データベースを読み込んでいます ... 現在 139971 個のファイルとディレクトリがインストールされています。)
libssp0-arm-cross 4.1.1-21(libssp0-arm-cross_4.1.1-21_all.deb で) 置換するための準備をしています ...
libssp0-arm-cross を展開し、置換しています...
dpkg: 依存関係の問題により libssp0-arm-cross の設定ができません:
 libssp0-arm-cross は以下に依存 (depends) します: gcc-4.1-base (= 4.1.1-21) ...しかし:
システム上の gcc-4.1-base のバージョン は 4.1.2-25 です。
dpkg: libssp0-arm-cross の処理中にエラーが発生しました (--install):
 依存関係の問題 - 設定を見送ります
以下のパッケージの処理中にエラーが発生しました:
 libssp0-arm-cross

を見るととそうっぽい。うーんdebian自体のgcc-4.1-baseを下げるか?
それともarmadilloのクロスパッケージをdpkg-crossでつくるか?
debiaんのバージョンもどしはてっとり早くやるには、/etc/apt/sources.listをetchに合わしてaptitude でとってくればいいのかな?あんまりいいやり方でもない気がするけど。


力技だけどダウングレードで解決